[Coladam] More fun adventures in CP/M

bytehacker at tallcedarskennels.com bytehacker at tallcedarskennels.com
Tue Feb 23 18:33:27 CET 2010


Let me try the permissions thing first, Steve. Up till yesterday I hadn't booted the Vista box in over a year and a half, so I'm not sure what user setup I had. Also you might well be right about the TDOS disk sizes. My collection of disk images is such that I really have no idea where they came from, or what systems they were set up for. 

I will keep playing for a bit.  My usual learning method is to find out what doesn't work first.

Just for the record, I want to say that I really like Virtual Adam. You've done a suberb job on the user interface, and it's a pleasure to use. So if I can help with the debugging efforts, I'll be more than happy to do so.  

Now .....  The ultimate question.  Any chance the source could be compiled for a PPC or Intel Mac? 
(Evil grin)
Ron
------Original Message------
From: Steve Pitman
To: Ronald Mitchell
To: Joe Blenkle
Cc: coladam at adamcon.org
Sent: Feb 23, 2010 07:30
Subject: Re: [Coladam] More fun adventures in CP/M

I suspect that the TDOS image you are booting isn't configured to see the B: 
drive properly.  That was always the most difficult thing when dealing with 
TDOS or CP/M,  anytime you use a different size media or drive you have to 
reconfigure the OS to recognize the drive properly.

Ron, Virtual Adam has been tested in Vista and Windows 7 and ran fine but 
there were a couple of people that had problems like you are having.  They 
were permissions related, I use XP so I probably won't be much help with 
troubleshooting but maybe right click on the installer and run it as 
administrator?

For one person we just skipped the installer altogether and that fixed the 
problem, I just e-mailed him the files in zip format and he extracted them 
to a folder.  I can send them to you in that format if you'd like.


----- Original Message ----- 
From: "Ronald Mitchell" <bytehacker at tallcedarskennels.com>
To: "Joe Blenkle" <jblenkle at sacnews.net>
Cc: <coladam at adamcon.org>
Sent: Monday, February 22, 2010 11:22 PM
Subject: Re: [Coladam] More fun adventures in CP/M


> No idea at all.
>
> Haven't had the problem with Adamem under my usual setup. But then I
> haven't been using Virtual Adam.
>
> I'm using a Mac, and the only way I can run Virtual ADAM there is
> under the Q-Emulator with Windows 2000. (Talk about a real house of
> cards). Unfortunately, it runs slower than Canadian Molasses uphill in
> January. However, I was able to boot the two TDOS disk images I
> recently prepared, and successfully copy files from one disk to the
> other and back using the COPY command. Slow, but it worked.
>
> So I took my VISTA box out of storage,  (1.8 GIG processor and 1 Gig
> or RAM) and downloaded Virtual ADAM there. Couldn't load  any disk
> images at all.  Kept getting an "Error 5" when attempting to boot
> either a TDOS image or an EOS image.
>
> So I shall have to figure out what that is all about. Meantime, I'm
> not really able to answer your question.
>
> Leave it with me. Maybe somebody else on here has a thought or two.
>
> Ron
>
> On 21-Feb-10, at 12:16 PM, Joe Blenkle wrote:
>
>> Any clue why when I try to copy files between TDOS disks using
>> Virtual ADAM I get I/O Error?
>>
>> I type in:
>>
>> COPY A:FILENAME.COM B:
>>
>> and when I press ENTER it just says:
>>
>> I/O Error
>>
>> thanks
>>
>> Joe B.
>
> _______________________________________________
> Coladam mailing list
> Coladam at adamcon.org
> http://adamcon.org/cgi-bin/mailman/listinfo/coladam 



Sent on the TELUS Mobility network with BlackBerry


More information about the Coladam mailing list