[Coladam] More fun adventures in CP/M

Ronald Mitchell bytehacker at tallcedarskennels.com
Thu Mar 4 05:13:25 CET 2010


Yes it does mess things up, but there's a way around it.

When you install the system on a particular disk, the install program  
asks you what size your drives are. It's capable of telling how many  
drives are connected, but not whether they're 5-1/4 or 3-1/2 or double  
sided or single sided, or high density and the like. If  you're  
running TDOS on the emulator, the TDOS install program will always  
pick up 4 disk drives. So when you run the program 40TDOS45.COM   
(which is the generic system install, ie no hard drives, or specific  
vendor's serial ports and 40 col screen output),  it will ask you for  
the sizes of disk drives 1, 2, 3, and 4.  It gives you a list of  
available sizes and densities to choose from so it's just a case of  
entering the number of the appropriate choice.  If you only intend to  
use 2 of those drives, enter a value anyway, but just don't try to log  
onto the drives you're not using.

If you take that disk with the system generated on it and boot it on  
some other system, it will expect to find the same drives as were  
installed on the original system, and that may or may not be the case.

So what you do is run the program

DRIVES.COM

in some cases if might be DRIVES12.COM

That will tell you what drives and sizes the system expects to see.   
If that happens to be different from what you've actually got  
connected, then you have to tell the system what drives ARE connected.

So you run the program  DSKSZ.COM  (or as it's distributed,  
DSKSZ25.COM).

That program prompts you one drive at a time for the size of each  
drive, and again a list of available sizes and densities appears, and  
you select the appropriate one.

You're then good to go.......

Until you reboot the system again.

To get around that, you have to re-install TDOS on your system,  (ie  
-- overwrite the system tracks already there) to reflect the drive  
sizes and densities you have connected. So you need to run  
40TDOS45.COM again.

It can be a pain, and toward the end of Guy Cousineau's work with TDOS  
he actually began to recognize that. We had all sorts of different  
systems out there with varying serial port outputs, screen outputs,  
hard drives/no hard drives, different densities, yada yada.   Boot an  
80 column TDOS disk set up for Orphanware serial output for example,  
on a 40 col monitor, and you got nothing but a blank screen.

And you're forced to conclude that the damn thing doesn't work. It  
does, but it's feeding the screen output to a different port than the  
one you've got your monitor connected to.

When it comes to setting up disks, there's also my earlier point about  
funning FLSHDIR.COM on Micro Innovations high density disks  or 720k  
disks after formatting.  Unless you do that, you get gibberish when  
you type DIR

All serves to keep us up late at night trying to remember how the  
ruddy thing worked.

Ron Mitchell


On 3-Mar-10, at 1:05 PM, Joe Blenkle wrote:

> Ron...just curious though...since TDOS seemingly is very picky about  
> how it is set up, doesn't it being configured four four disk drives  
> and two data drives mess it up?
>
> What hapens if you only have one disk drive and one data drive?  
> Isn't there someway of telling it what you have installed on your  
> system?
>
> And on another note, using Virtual ADAM or ADAMem...even if I have  
> the program set for four disk drives and put disks in them, I have  
> never been able to access them...likewise with the ramdisk...
>
> Guess it will take a lot of experimentation to get it right.
>
> Joe B.
>
> ----- Original Message ----- From: "Ron Mitchell" <bytehacker at tallcedarskennels.com 
> >
> To: "Joe Blenkle" <jblenkle at sacnews.net>
> Cc: <coladam at adamcon.org>
> Sent: Friday, February 26, 2010 8:32 PM
> Subject: Re: [Coladam] More fun adventures in CP/M
>
>
>> Joe, the emulator sets up for 4 disk drives and 2 tape drives.  
>> Seems to
>> be that's the way it's configured. TDOS sets up a system with  
>> whatever
>> drives and drive sizes were connected when it was installed on that
>> particular disk. That can mean trouble when you try to run TDOS on
>> another system that is not similarly equipped to the one where it was
>> first installed.
>>
>> You can find out what drives and sizes TDOS is expecting to find by
>> running DRIVES.COM.
>>
>> If you try to access a drive that the emulator says it is supposed to
>> have, but you haven't assigned a disk image to it, TDOS will give  
>> you a
>> "missing media"  error message.
>>
>> Gets kinda confusing. The other thing is  (and I think I mentioned  
>> this
>> on here already) that if you want to use a 1.4 Meg  or 720K disk for
>> TDOS, you have to use FLUSHDIR.COM to initialize the directory.
>> Otherwise you get gibberish when you type DIR.
>>
>> Ron Mitchell
>>
>>
>>
>>
>>
>>
>>
>> On Tue, 2010-02-23 at 09:56 -0800, Joe Blenkle wrote:
>>> Steve, that may well be. I'm trying to copy files between a 160k  
>>> TDOS disk
>>> and a 320K TDOS disk. It took me forever just to get it configured  
>>> so it
>>> would format the 320K disk correctly. Perhaps it is misleading  
>>> when the
>>> 40TDOS45 program tells you to pick the drive sizes. It says  
>>> "Maximum size of
>>> drive"...so I picked all 320K drives. Maybe you have to pick the  
>>> "exact"
>>> size of the drive.
>>>
>>> I also don't understand why it sets your system up for four disk  
>>> drives when
>>> I only have two installed. It also supposedly sets the RAMDRIVE as  
>>> Drive G,
>>> but I don't seem to be able to access it either.
>>>
>>> I'll keep trying!!!
>>>
>>> Joe B.
>>>
>>>
>>> ----- Original Message ----- From: "Steve Pitman" <swp at cinci.rr.com>
>>> To: "Ronald Mitchell" <bytehacker at tallcedarskennels.com>; "Joe  
>>> Blenkle"
>>> <jblenkle at sacnews.net>
>>> Cc: <coladam at adamcon.org>
>>> Sent: Tuesday, February 23, 2010 7:30 AM
>>> Subject: Re: [Coladam] More fun adventures in CP/M
>>>
>>>
>>> >I suspect that the TDOS image you are booting isn't configured to  
>>> see >the
>>> >B: drive properly.  That was always the most difficult thing when  
>>> >dealing
>>> >with TDOS or CP/M,  anytime you use a different size media or  
>>> drive you
>>> >have to reconfigure the OS to recognize the drive properly.
>>> >
>>> > Ron, Virtual Adam has been tested in Vista and Windows 7 and ran  
>>> fine > but
>>> > there were a couple of people that had problems like you are  
>>> having. > They
>>> > were permissions related, I use XP so I probably won't be much  
>>> help > with
>>> > troubleshooting but maybe right click on the installer and run  
>>> it as
>>> > administrator?
>>> >
>>> > For one person we just skipped the installer altogether and that  
>>> fixed > the
>>> > problem, I just e-mailed him the files in zip format and he  
>>> extracted > them
>>> > to a folder.  I can send them to you in that format if you'd like.
>>> >
>>> >
>>> > ----- Original Message ----- > From: "Ronald Mitchell" <bytehacker at tallcedarskennels.com 
>>> >
>>> > To: "Joe Blenkle" <jblenkle at sacnews.net>
>>> > Cc: <coladam at adamcon.org>
>>> > Sent: Monday, February 22, 2010 11:22 PM
>>> > Subject: Re: [Coladam] More fun adventures in CP/M
>>> >
>>> >
>>> >> No idea at all.
>>> >>
>>> >> Haven't had the problem with Adamem under my usual setup. But  
>>> then I
>>> >> haven't been using Virtual Adam.
>>> >>
>>> >> I'm using a Mac, and the only way I can run Virtual ADAM there is
>>> >> under the Q-Emulator with Windows 2000. (Talk about a real  
>>> house of
>>> >> cards). Unfortunately, it runs slower than Canadian Molasses  
>>> uphill in
>>> >> January. However, I was able to boot the two TDOS disk images I
>>> >> recently prepared, and successfully copy files from one disk to  
>>> the
>>> >> other and back using the COPY command. Slow, but it worked.
>>> >>
>>> >> So I took my VISTA box out of storage,  (1.8 GIG processor and  
>>> 1 Gig
>>> >> or RAM) and downloaded Virtual ADAM there. Couldn't load  any  
>>> disk
>>> >> images at all.  Kept getting an "Error 5" when attempting to boot
>>> >> either a TDOS image or an EOS image.
>>> >>
>>> >> So I shall have to figure out what that is all about. Meantime,  
>>> I'm
>>> >> not really able to answer your question.
>>> >>
>>> >> Leave it with me. Maybe somebody else on here has a thought or  
>>> two.
>>> >>
>>> >> Ron
>>> >>
>>> >> On 21-Feb-10, at 12:16 PM, Joe Blenkle wrote:
>>> >>
>>> >>> Any clue why when I try to copy files between TDOS disks using
>>> >>> Virtual ADAM I get I/O Error?
>>> >>>
>>> >>> I type in:
>>> >>>
>>> >>> COPY A:FILENAME.COM B:
>>> >>>
>>> >>> and when I press ENTER it just says:
>>> >>>
>>> >>> I/O Error
>>> >>>
>>> >>> thanks
>>> >>>
>>> >>> Joe B.
>>> >>
>>> >> _______________________________________________
>>> >> Coladam mailing list
>>> >> Coladam at adamcon.org
>>> >> http://adamcon.org/cgi-bin/mailman/listinfo/coladam
>>> >
>>>
>>
>>
>



More information about the Coladam mailing list