[Coladam] Dr. D. HD system update

Rich Drushel drushel at apk.net
Sat Jan 8 21:12:08 CET 2011

     Hi all, I dug out some ADAM stuff today and set up a corner of
the living room so I can have an ADAM setup.  The object was to get
my Mini Winnie HD system working so that I could get at the ADAMlink V
installation stuff.

     Starting slow, I tested some other ADAM system units.  The R80s
that were used as timer and scoreboard for my old LEGO robotics course
worked fine.  (They last would have been used in December 2004.)  One
of these actually has the R80FR French SmartWriter ROMs installed.  This
one was also the system that I used in my slug video research 15 years
ago (published in 1997, complete with picture of an ADAM, Journal of
Experimental Biology 200:735-752). My Dad's original R59 ADAM also booted,
after a few reseatings of the power connector.

     Moving to the HD system...this was my grand all-in-one:  20 MB MFM
HD (mounted internally, side power jack, front-panel activity LED), 256K
XRAM, MIB2 card with 2 serial ports and parallel port (routed to 2 external
DB9 and 1 DB25 connector), Orphanware serial card mounted internally (routed
to external DB25 connector, external baseport select switches, and ribbon
cable routed to the sideport to accept 1 additional sideport device), 2400
baud pocket modem (mounted internally, attached to MI serial port #1 with
external phone jack), internal audio amp/speaker (mounted in tape 1 bay
using dummy DDP frame assembly), and no-slot clock (I bet the 10-year
battery is dead).  There is probably some TWWMCA article describing it in
more detail.

     In any case, I plugged everything in and powered it all up, and
got nothing on the TV.  I carefully pulled and reseated the cards and
connectors that I could reach, but nothing :-(

     The HD does not spin up, but the activity light blinks in a repeated
pattern, so it's trying to do something.  Since MFM drives have the
controller on an external board, I am going to presume for now that the
failure to spin up is due to the ADAM not booting.  I can't remember if,
in the past, the drive would spin up on its own, with no working ADAM.
When I took the HD out of the ADAM and had it hooked up just to its power
supply (no ribbon cables attached), it didn't spin up, but did repeat the
blinking pattern of the activity light.  I tried my 2 different HD power
supplies, same result.

     I do remember that past failure of this all-in-one system to boot just
as an ADAM (no HD) was likely due to a loose connector or ribbbon cable for
the internal Orphanware serial board.  As you can imagine, mounting all this
stuff internally was quite a feat, and it was always a pain to get it all to
go back together.  Looks like I have no choice but to take it apart and hope
I can remember how to get it all back in again.

     If the HD is dead, I will be very, very sad.  The HD is a 3.5"
MiniScribe dated 14 October 1988.  I think I bought the system from Herman
and George around 1994.  I did make at one time a complete image of the ten
1MB EOS volumes onto 1.44 MB floppy (1 disk per volume), and I am certain
that I have all those disks, so would just be a matter of moving the
ADAMlink V development stuff off of them.  There is also a chance that I
have an ADAMserve version of that HD image, though my 486 system that I
used with ADAMserve is dead (motherboard failure).  I got everything off
the HDs of my 486, just a matter of setting up another old PC system.  I
have a P3-450 Win98 system in storage at work, which probably would work if
booted in MS-DOS mode.

     Herman, George, Bob, do any of you remember if an MFM HD is supposed
to spin up on its own when powered, regardless if the ADAM is powered
up/booted?  If it's supposed to be spinning now, then it is a very bad
sign.  However, if all I need to do is get the ADAM working first, and
then the drive will "know" to spin up, then all will be well.

     Wish me luck!

     *Dr. D.*

Richard F. Drushel, Ph.D.            | "They fell:  for Heaven to them no hope
Department of Biology                |  imparts / Who hear not for the beating
Case Western Reserve University      |  of their hearts."
Cleveland, Ohio  44106-7080  U.S.A.  |         -- Edgar Allan Poe, "Al-Aaraaf"

More information about the Coladam mailing list